안녕하세요 Cellularhacker입니다.

지난번 DB설계 이후에 초기설치용 SQL문을 작성하였습니다.

이 과정에서 DB구조상의 문제(Multiple Primary Key - MySQL/MariaDB에서는 지원하지 않음)등을 수정하고,

설치용 SQL을 작성하였습니다.


해당 DB 변경내용은 이전 게시글에 올렸던 링크에도 반영되어 있으니 확인하실 수 있습니다.



CATEGORY테이블에 Korea Decimal Classification ver.6 를 기준으로 한 분류기호를 등록하는 과정도 포함되어 있습니다.


나중에 개인 Public API서버에 KDC6분류기호를 가져갈 수 있도록 추가해야겠네요.(http://api.hackbot.kr, Git)




'Project > PZLAS I' 카테고리의 다른 글

[PZLAS] 01-1.DB수정 및 초기설치용 SQL작성  (0) 2018.12.25
[PZLAS I] 01.PZLAS DB설계  (0) 2018.12.20
[PZLAS I] 00.PZLAS 프로젝트 시작 알림  (0) 2018.12.20

안녕하세요 Cellularhacker 입니다.

PZLAS I에서 사용할 DB를 설계 하였습니다.


(https://dbdiagram.io/d/5c1b49a595949f0014a8772b)

위 내용에서 큰 변화는 없을 것으로 생각하고 있습니다.


라이센스는 CC-BY-NC-SA 4.0 International 이며, 자세한 내용은 이전 게시글 참고 부탁드립니다.

감사합니다.

'Project > PZLAS I' 카테고리의 다른 글

[PZLAS] 01-1.DB수정 및 초기설치용 SQL작성  (0) 2018.12.25
[PZLAS I] 01.PZLAS DB설계  (0) 2018.12.20
[PZLAS I] 00.PZLAS 프로젝트 시작 알림  (0) 2018.12.20

안녕하세요 돌아온 Cellularhacker 입니다.

모든 PZLAS 프로젝트의 시작을 알리고자 오랜만에 글을 쓰게 되었습니다.

PZLAS I부터 시작하며, PZLAS II로의 개편을 계획하고 시작됩니다.


README 내용은 다음과 같습니다.


[저작자]
 - Cellularhacker

[GitHub 페이지]
 - https://github.com/Cellularhacker/PZLAS-I

[라이센스]
 - 코드에 대한 라이센스: The BSD 4-Clause License
 - 그림, 사진, 설명 텍스트 등 출력물에 대한 라이센스: CC-BY-NC-SA v4.0 International

[프로젝트명의 유래]
 - PZGS(모 대학의 만화동아리 이름) + KOLAS III (대한민국정부에서 보급하는 표준자료관리시스템)

[개요]
 - 대학 만화 동아리내에서, 동아리방(이하 동방)에 기증된 여러가지 책을 Web based application을 이용하여 편리하게 관리하기 위하여 시작되었으며,

본 프로젝트는 동아리내 물품관리서비스를 개발하기 위한 연구용 초석으로 사용될 예정입니다.

[목표]
1) PZLAS I
 - Web을 기반으로한 Standalone Library-Admin-System을 구현
2) PZLAS II
 - Project.ARUGS 완료 혹은 개발 진행 중 DB설계 및 API가 구현되는 때부터 적용, 동아리시스템 내부 API를 이용하여 회원정보를 참조하도록 PZLAS의 DB설계변경

[개발환경]
 - DB: RDBMS=MariaDB 10.x
 - Backend: Node.js
 - Frontend: React.js


현 시점을 기해, PZLAS I의 개발이 이미 시작되었음을 공개합니다.



'Project > PZLAS I' 카테고리의 다른 글

[PZLAS] 01-1.DB수정 및 초기설치용 SQL작성  (0) 2018.12.25
[PZLAS I] 01.PZLAS DB설계  (0) 2018.12.20
[PZLAS I] 00.PZLAS 프로젝트 시작 알림  (0) 2018.12.20

안녕하세요. Cellularhacker입니다. 굉장히 오랜만에 인사드리는 것 같습니다.


이번에는 리눅스 환경에서 기본적으로 설치되는 패키지들을 이용해서 파일을 압축/풀기를 하는 방법에 대해서 소개하겠습니다.



먼저, tar의 개념에 대해서 알아보겠습니다.

tar란, Unix/Linux에서 사용되는 파일 아카이브(archive)를 하기 위해 사용되는 명령어 입니다. 여기서 아카이브라고 하면, 말 그대로 저장을 하는 의미이지만 조금 생소한 단어이지요.

조금더 쉽게 이야기하면, "여러개의 파일이나 디렉터리를 쉽게 보관하기 위해 하나의 파일로 만드는 작업"이라 할 수 있습니다.


표기를 하자면, [여러개 파일] or [디렉터리] --> [하나의 파일] 이 되겠네요.



<tar의 사용법>

  • 아카이브(tar로 묶기)
    tar -cvf 보관할_파일이름.tar 보관할_파일1 [보관할_파일2 보관할_디렉터리1 ...]
      대괄호가 묶여있네요. 즉, 파일 하나 혹은 디렉터리 하나를 지정해도 되고, 여러개를 뒤에 붙여도 된다는 말입니다.


<tar_1.png>


  • 아카이브 풀기
    tar -xvf 아카이브_파일.tar
      이렇게 명령을 입력하여 아카이브(tar)를 풀게되면, 아카이브(tar, 묶을 때) 있었던 디렉터리 구조 그대로 압축이 해제 되게 됩니다. 조금 말이 어려운가요? 그러면 보기 쉽게 트리 구조로 나타내어 보겠습니다.

    tmp (현재 디렉터리)
     ㄴ file1
     ㄴ txt1.txt
     ㄴ txt2.txt
     ㄴ archive/
          ㄴ abc.txt
          ㄴ bcd.txt
          ㄴ efg.txt

    이런 트리 구조로 되어있던 파일을 tar로 묶었을때, 풀었을 때에도 위와 똑같은 구조로 나온다는 뜻입니다.

<tar_2.png>


  • 아카이브 된 내용 보기
    tar -tvf 아카이브_파일.tar
      놀랍게도(?) tar는 아카이브된 파일에 어떠한 것들이 들어있는지를 알 수 있는 미리보기 기능이 있습니다. 결과 화면은 'ls -al' 과 유사합니다.





오늘은 tar의 정말 기본적이고 자주 쓰이는 옵션들과 함께 알아보았습니다. 다음 시간에는 gzip과 bzip2에 대하여 알아보도록 하겠습니다.


부족한 글 읽어주셔서 감사합니다.


- Cellularhacker -

안녕하세요~ 오랜만에 돌아온 Cellularhacker입니다.
최근에 일정이 너무 겹치는 바람에 제 공부도 소흘했던 것 같습니다^^;
이번에는 Vim에서 특정 문자열을 치환, 즉 바꾸는 방법에 대해서 알아보겠습니다.
사용 되는 명령은 다음과 같습니다


:%s/[치환할 대상]/[치환할 내용] 


바로 실전에 들어가보겠습니다.


조금 전까지만 해도 제가 삽질을 하고 있었던건 Telegram 으로 서버 모니터링을 해보기 위하여 설정 중에 있었습니다. 물론 이것을 X11설치하고... GNOME 설치하고... ssh -X 로 열어서 gedit으로 해도 되지만... 이것을 비효율 적입니다. CLI(or TUI)환경에 익숙하신 분들이시면 아마 일부러 vim을 더 많이 쓰실지도 모른다는 기대를 하면서...

:%s/home\/Username/root 

를 입력하면...













짜잔!  쉽게 변경 된 것을 확인 할 수 있습니다. 위 명령어가 동작했다는 사실을 토대로 경로를 입력 하고 싶을때에는 늘 그랬듯이 역슬러시(\)를 사용하면 되는 것을 알 수 있습니다.


(그나저나 저거 삽질 성공하신 분 계신가요? 전 왜 안될까요..)

Hello Everybody. This is Cellularhacker.

The Shell Shock zero day. Did you patched it?

It was really shocked for me; So I patched it quickly.


What is Shell Shcok?
http://www.engadget.com/2014/09/25/what-is-the-shellshock/


@Debian Based (ex. Ubuntu, Mint, etc)

Upgrade all packages.

$ sudo apt-get update && sudo apt-get upgrade

Up grade only bash package.

$ sudo apt-get update && sudo apt-get install --only-upgrade bash


@Red Hat Based (ex. CentOS, Fedora, etc)

# yum update bash


@Arch Linux Based

# pacman -Syu


@OS X   (From : Shellshocker.net)

Use brew

brew update
brew install bash
sudo sh -c 'echo "/usr/local/bin/bash" >> /etc/shells'
chsh -s /usr/local/bin/bash
sudo mv /bin/bash /bin/bash-backup
sudo ln -s /usr/local/bin/bash /bin/bash

Use MacPorts

sudo port self update
sudo port upgrade bash



It is convenient to use the code below:  (From : LinuxNewsPro)


1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
#!/bin/bash
# This script will log into each of your servers and execute the command below
 
servers=(
# Put your list of servers here
111.222.333.444
123.123.123.123
10.10.10.10
15.22.22.22
)
for server in ${servers[@]}
do
# Here's the command you're going to run on each
ssh $server 'yum -y update bash'
done



( * You can also see in these web sites: www.hackbot.kr | cellularhacker.cisaid.net | blog.naver.com/hackbot01 )

'Notice' 카테고리의 다른 글

Did you patched Shell Shock?  (0) 2014.09.27
배쉬 쉘 쇼크(Bash Shell Shock) 패치하셨나요?  (1) 2014.09.27

안녕하세요. Cellularhacker입니다.

환경변수 값을 이용하는 쉘 쇼크. 다들 패치 하셨나요?

저도 오늘 깜짝 놀라서 학교에서 쉬는시간에 서버 7대 모두 패키지를 업그레이드 하였습니다.


Shell Shock 기사
http://www.metroseoul.co.kr/news/newsview?newscd=2014092600243


@데비안 계열 

패키지 모두 업그레이드

$ sudo apt-get update && sudo apt-get upgrade

bash 패키지만 업그레이드

$ sudo apt-get update && sudo apt-get install --only-upgrade bash


@Red Hat 계열

# yum update bash


@Arch Linux 계열

# pacman -Syu


@OS X   (출처 : Shellshocker.net)

Brew 사용

brew update
brew install bash
sudo sh -c 'echo "/usr/local/bin/bash" >> /etc/shells'
chsh -s /usr/local/bin/bash
sudo mv /bin/bash /bin/bash-backup
sudo ln -s /usr/local/bin/bash /bin/bash

MacPorts사용

sudo port self update
sudo port upgrade bash



서버들을 한번에 패치 하시려면 아래 코드를 이용하시면 편리합니다.   (출처 : LinuxNewsPro)


1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
#!/bin/bash
# This script will log into each of your servers and execute the command below
 
servers=(
# Put your list of servers here
111.222.333.444
123.123.123.123
10.10.10.10
15.22.22.22
)
for server in ${servers[@]}
do
# Here's the command you're going to run on each
ssh $server 'yum -y update bash'
done




내용추가하겠습니다. 현재 Bash 에서 추가적으로 패키지 업데이트가 있는 것을 확인하였습니다.
저도 조금전에 패키지를 업데이트 하였습니다. 업데이트 내용은 시간이 나는대로 추가하겠습니다. 감사합니다.



( * 본 게시물은 www.hackbot.kr | cellularhacker.cisaid.net | blog.naver.com/hackbot01 에서 보실 수 있습니다.)

'Notice' 카테고리의 다른 글

Did you patched Shell Shock?  (0) 2014.09.27
배쉬 쉘 쇼크(Bash Shell Shock) 패치하셨나요?  (1) 2014.09.27
  1. [Pure] HackBOT 2014.09.30 23:14 신고

    현재 Apple 에서 Mac OS X 를 대상으로 공식 업데이트를 배포하였습니다.

음... 아시는 분은 이미 아시겠지만, 전 CISAID라는 단체(? 회사?)의 일원 입니다.

현재 CISAID MC를 운영하고 있는 운영진 중 한 명으로 있습니다.

오늘 2U서버를 추가로 파킹을 해서, 기존에 1U서버위에 VM으로 운영한 MC서버를 1U 호스트로 넘겨주고, 1U서버에 돌아가던 다른 VM들은 2U서버에 VM으로 넣었습니다. 

음... 2U서버 파킹하니 확실히 1U서버보다는 비용이 비쌉니다...

전 개인적으로 ipfuse(아마도 동의정보시스템으로 이름을 바꾸는 것 같습니다.) 라는 회사를 이용하는데...음... 2U하니 2년 계약에 월 10만원(제 견적은 VAT포함 인 것 같습니다.) 40Mbps회선으로 해주겠다고 하더군요...

음... 다른 곳을 잘 안써봐서 잘은 모르겠는데... 이정도면 뭐 나름 싼 것 같습니다..

1U서버 하나는 30Mbps에 2년 계약하고 있고... 이건 대략 한 7~8만원 정도 내는 것같습니다.

VPS도... 잠깐 쓰실거라면... 괜찮은 것 같습니다. 저번에 MC 이벤트 서버를 임시로 쓴적이 있었는데.. 좀 성능 옵션 좀 넣었는데.. 한 5만원 정도 나온 것 같습니다.

이정도면 나쁘지는 않은 건가요?

'Diary' 카테고리의 다른 글

서버 이전...  (0) 2014.07.30
C강의 연재를 시작합니다..  (0) 2013.06.01
모자 뜨기 캠페인에 참여해요!  (0) 2012.12.20
2012-04-02 10:35 벤치비로 인터넷 속도측정 결과  (0) 2012.04.02
으악!!!  (1) 2012.03.27

... OSPF프로토콜 연습을 하고 있었는데....

어째서인지 Totally-Stub Network에 있는 라우터들에게....
ABR라우터가 O*IA로 올라오질 않네요;;; 대체 왜이럴까요;;



R3#show run
Building configuration...

Current configuration : 1518 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
ip tcp synwait-time 5
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!

!

!
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
ip address 192.168.0.9 255.255.255.252
ip ospf 1 area 0
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
ip address 192.168.0.6 255.255.255.252
ip ospf 1 area 0
clock rate 2000000
!
interface Serial0/2
ip address 192.168.3.1 255.255.255.252
ip ospf 100 area 3
clock rate 2000000
!
interface Serial0/3
ip address 192.168.3.10 255.255.255.252
ip ospf 100 area 3
clock rate 2000000
!
interface Serial0/4
no ip address
shutdown
clock rate 2000000
!
interface Serial0/5
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
!
router ospf 1
log-adjacency-changes
!
router ospf 100
log-adjacency-changes
!
!
!
no ip http server
no ip http secure-server
!
!

!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end

R3#


R7#

R7#show run
Building configuration...


Current configuration : 1425 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R7
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
ip tcp synwait-time 5
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!

!

!
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
interface Serial0/2
ip address 192.168.3.2 255.255.255.252
ip ospf 100 area 3
clock rate 2000000
!
interface Serial0/3
ip address 192.168.3.5 255.255.255.252
ip ospf 100 area 3
clock rate 2000000
!
interface Serial0/4
no ip address
shutdown
clock rate 2000000
!
interface Serial0/5
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
!
router ospf 100
log-adjacency-changes
area 3 stub
!
!
!
no ip http server
no ip http secure-server
!
!
!
!

!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login 
!
!
end

R7#


'Network > CCNP(Router)' 카테고리의 다른 글

OSPF오류.....  (0) 2014.02.18

안녕하세요. Cellularhacker입니다.

이번에는 여러분들이 한두번 쯤은 접해 보셨을 것 같은 것을 만들어 보려고합니다.

예를들면.. 가방컴이라던가......네... 그런거요..

이거 사실 올해 해커스쿨 하계해킹캠프후에 매미님이 동계때는 가방컴(?) 들고 오겠다고 하신 글을 보고 아 맞다 3년전에 나도 했었지.... 라며 추억에 잠기면서 말도안되는 공약을 했었는데...

그리하여... 계획수정에 이르고....
Portable하긴 하지만 운반이 어려운 대신 확장이 용이한 걸 만들어 볼려고 합니다...
제가 요즘 워낙 mini pci-e 카드에 빠져있어서....

일단 소프트웨어 or 하드웨어 상에서 넣을 기능 등 입니다.
1. Intel Centrino Advanced-N Wireless mini pci-e
2. Intel Centrino Advanced-N WiMax 6250
3. NAT
4. DHCP
5. Switch(5 ports)

대충 이정도 밖에 아이디어가 나질 않네요 ㅠㅠ

일단 화이팅! 아자아자!

'Project' 카테고리의 다른 글

[New] Portable PC  (1) 2013.10.20
[NEW] Non-Dock Docking HUB  (0) 2013.10.18
[중요] UTP 자동 셀렉터 - 기획  (0) 2013.01.03
전기요금 줄이기 대작전!  (0) 2012.12.16
  1. 매미 2013.11.25 23:12 신고

    끵... 돈이란게 없어서 가방컴이란건 결국 ㅠ

+ Recent posts